Material with Texture doesn't consider lighting?

Dec 6, 2009 at 1:13 PM
Edited Dec 6, 2009 at 1:14 PM

I am trying to attach a texture to an object and having lighting on it, but seems material with texture doesn't consider lighting, is this feature ready for use?

Dec 6, 2009 at 4:13 PM

Shading on texturemapping has not been implemented yet. Its in the pipeline, though:


Can't guarantee when it will be implemented.

Apr 23, 2010 at 2:41 PM

I must say that I have been very impressed with what I have seen of this engine so far, and the only thing stopping me from using it in a professional environment is this lack of texture shading. I'm sure you're very busy, but it would be fantastic if you could estimate a date when this would be implemented by.

Thanks, and keep up the awesome work!

Apr 24, 2010 at 5:20 AM


I've started implementing shaded textures with support for both flat shaded and gouraud shaded. Its hard to commit to a date, but I guess sometime during may would be realistic to estimate.

Apr 24, 2010 at 5:28 AM

Gald to hear that. One more question, do we have transparency object in balder ?

Apr 24, 2010 at 6:33 AM

The transparency will be done in the same go. I've started both tasks.

Oct 1, 2010 at 11:51 AM

Hi adept, is this feature implemented yet? If not, when we'd expect this? It seems to be pretty old issue :)

[ Cause, when I redefine shading of (textured) material, it redefines the whole material and removes the texture from object. What I'm doing wrong, please? ]


                box = renderContext.ContentManager.Load<Mesh>("ES_45.ASE");
                box.Material = new Balder.Materials.Material();
                box.Material.Shade = Balder.Materials.MaterialShade.Gouraud;

Oct 1, 2010 at 1:09 PM


are you using the latest binary release ( or have you downloaded the source and compiled it? The version does not take this into account, but the latest source does. Lighting has improved a lot with the latest source.

I have been supposed to drop a binary for a while now, but haven't had the time. Work is getting in the way.. :)

Oct 1, 2010 at 1:16 PM

Oh, I'm using binaries of Oki, i will try the source code. Thank you very much for quick response ;)




Oct 1, 2010 at 7:56 PM

Sure, no problem. 

You can build either through Visual Studio or the build script in the root of the project by typing "build All" from a command line.