Mouse events

Sep 27, 2010 at 11:42 AM

Hello, i faced with following issues:

a) Mouse events aren't being fired when camera is closed to node

b) Sprite node doesn't fire any event at all

Is there any chance to get these issues fixed in near future?

Sep 27, 2010 at 12:23 PM

Define near future.. :) 

I'm very busy this week and next week and have not got any Balder time allocated at all.


How close is close to the node? 

Sep 29, 2010 at 7:39 PM

"Close" is case when size of rendered node is bigger than viewport size :) I moved away camera a bit, that helps, but now smaller nodes that arranged around big one aren't firing any events.

Sep 30, 2010 at 5:55 AM


I'll be back in business in the middle of next week and will have a chance during the last part of the week to look at this and a couple of other problems.

Sep 30, 2010 at 6:54 AM

Great, Thank you. And please remember - you can have a live view of the problem ;)


Sep 30, 2010 at 8:12 AM

Excellent point. I'll do that. 

Sep 30, 2010 at 8:16 AM

Dmitriy - can you please advise adept a set of coordinates?

Oct 1, 2010 at 7:55 PM


I've thinking about having a property called IsHitTestEnabled or similar, would that be helpful for you guys? 
From your application point of view, the large objects might not be interesting to get events from anyways.

It clearly doesn't really solve the problem you describe - so consider this sort of a sidetrack, as I want to get to bottom of the problem. :)

If you have coordinates, love to get them..  

Oct 1, 2010 at 8:29 PM

Try (2.2, 2.2, 2.2). When one node is partially overlapped with another node second one doesn't fire MouseEnter event at all.

Oct 2, 2010 at 5:28 AM

You got mail.