Mesh geometry ase not found

Sep 14, 2010 at 11:54 AM


I'm sure you've got this query many times but I still haven't found an answer.


I'm trying to load an ase file using the mesh and I get an 'Object reference not found' etc. error for the assetName.


The sample website project works fine (from the downloaded source files) but when I use my own project I get the error - even with ase files that were used in the same website.

I've actually used File to check if the uri I'm passing exists and it doesn't find the file even if I use say c:\hello.ase (it says file not found) - I understand that this may be due to the web browser but this also happens when I run my silverlight in an application, and yes I'm the administrator and I'm running visual studio as admin.

All other geometries in my project ex. box work fine, its just the mesh and just when I give it an assetName.

Please help





Sep 15, 2010 at 6:53 AM


sorry to hear you get this problem. Do you have camera or light definitions in the file, this is a known bug if you have that. 


Sep 15, 2010 at 7:35 AM


I don't think that's the problem, I'm using hello.ase which was supplied with the demo site and I've also copied all the code from the hello world sample.  Its just that the directory layout is different and I can't point it to the ase file.  I've also tried putting hello.ase in my c:\ folder and using assetname c:\hello.ase


any ideas?



Sep 15, 2010 at 7:49 AM

You can't point to files on your hard-drive, it needs to be in the Silverlight project, and you need either to have a Assets folder were you put it in or anywhere else and remember to set Build Action to Resource. 

More details :

Sep 15, 2010 at 8:01 AM


setting it to 'resource' build action did the trick! thank you very much