please help! urgent ASE file problem

Jan 7, 2011 at 5:53 PM
Edited Jan 7, 2011 at 5:59 PM

I have replace a working teapot mesh with my own object. But the ase file is not parsed correctly. I get a null refference here

teapot1 = Runtime.Instance.ContentManager.Load<Mesh>("bee.ASE");
resource action is set on bee.ase
I've tryed the the replacement of space, tab. I don't do something rights. Could you please tell me the exact things you do to make it work so I can do it next time.
Balder is great, beautiful work, i've just introduced 2 colleagues to 3d in silverlight with balder!
 Thanks in advance!
ase and max files for the bee
Jan 7, 2011 at 9:26 PM

I had similar problems loading ASE files based on the SLAR toolkit demo. Most of the ASE files that came with the demo wouldn't load. Some had obvious mistakes such as materials referring to absolute paths on the author's machine, and referring to image files using the wrong file extension. Some I managed to load by fixing problems like this. Some would load but not display. Some I never could get to load. I think the ASE file parsing in Balder is a little brittle and easily broken by minor changes in whitespace. I haven't found any documentation so far describing what the expected syntax is, and I'm too lazy to go look at the code myself. The error messages when it fails to load an ASE seem to be generally unhelpful so it is a matter of trial and error to guess what has upset it. Given the number of ways that a geometry can be defined in an ASE, it may be that there may be some parts of the ASE syntax that Balder simply doesn't support.

I tried to open your ASE file to see if I could recognise any of the errors that tripped me up, but the ZIP file I downloaded appeared to be corrupt so I gave up on that idea, sorry.

Jan 8, 2011 at 5:18 AM
Edited Jan 8, 2011 at 5:19 AM

Hi and thanks,

the file contained a Camera and a couple of Shapes, the ASE loader is very particular with what it expects.

The ASE loader is something that is on the list for a review. And also adding other formats. 

Mar 15, 2011 at 9:19 PM



I have a similar problem with my ASE.

I have also trying to remove space, and i have also tried with the latest library on the source section without success.

here is the file :

Thanks for help.



Mar 15, 2011 at 10:57 PM


If you have just dropped the file into the demo make sure that the Build Action for your model is set to Resource. I just dropped it in and renamed it teapot.ase

It takes a bit to load as its a complex model but it does load and render in Balder.


Hope this helps