no loader for ase

Dec 20, 2010 at 6:36 AM

Hello,

I'm trying out Balder and trying to load an ase mesh.  It is saying that there is no loader for the specified file type "ase".  any ideas?  Thanks!

Here's my code:

Imports Balder
Imports Ninject
Imports Balder.Objects.Geometries
Imports Balder.Materials
Imports Balder.Lighting
Imports Balder.Execution
Imports Balder.Content
 
Private Sub MainPage_Loaded(ByVal sender As Object, ByVal e As System.Windows.RoutedEventArgs) Handles Me.Loaded

        Dim krn As New Ninject.StandardKernel
        Dim ContentManager As New ContentManager(krn, New Content.ContentCache, New Assets.AssetLoaderService(New Execution.TypeDiscoverer, krn), New Content.ContentCreator(krn))
        Dim Scene As New Scene
        ContentManager.AssetsRoot = "img"
     
        Dim globe As New Balder.Objects.Geometries.Mesh
        globe = ContentManager.Load(Of Mesh)("earth2.ASE")
        globe.Position = New Balder.Math.Coordinate(0, 0, -100)
        Scene.AddNode(globe)

    End Sub

 

Coordinator
Dec 21, 2010 at 8:15 PM

Hi,

the reason is probably because you're trying to hook everything up yourself, but the dependencies should be managed internally by the internal Kernel that Balder creates itself. So the only way Balder is supported
at this stage is to create a Game, either Programatically or by adding it to the Xaml surface and use that, like the tutorials says, or the getting started video. 

Dec 22, 2010 at 7:50 AM

This also produces the same error when I try via XAML:

  xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:d="http://schemas.microsoft.com/expression/blend/2008"
    xmlns:mc="http://schemas.openxmlformats.org/markup-compatibility/2006"
               xmlns:Execution="clr-namespace:Balder.Execution;assembly=Balder"
    xmlns:Geometries="clr-namespace:Balder.Objects.Geometries;assembly=Balder"
    xmlns:View="clr-namespace:Balder.View;assembly=Balder"
    xmlns:Lighting="clr-namespace:Balder.Lighting;assembly=Balder"
    xmlns:Materials="clr-namespace:Balder.Materials;assembly=Balder"
    mc:Ignorable="d"
    d:DesignHeight="300" d:DesignWidth="400">

    <Grid x:Name="LayoutRoot" Background="White">
        <Execution:Game Width="640" Height="480" Name="baldurGame">
            <Execution:Game.Camera>
                <View:Camera Position="0,10,-15"/>
            </Execution:Game.Camera>
            <Lighting:ViewLight Diffuse="Red" />
            <Geometries:Mesh AssetName="earth2.ase"/>
        </Execution:Game>
    </Grid>
Coordinator
Dec 23, 2010 at 1:09 PM

Now, that was odd. Could you email me your solution? einar [at] dolittle [dot] com

May 13, 2011 at 6:01 PM

Hi,

I got the same problem. Is there any solution to that?

Coordinator
May 20, 2011 at 10:23 PM

As far as I recall, the specific problem was solved for alcitos517 - could you please post your project somewhere so I can take a look at it? 

May 22, 2011 at 2:10 PM

I read a little from last time, and I think it might not be the problem, becuse the message about the loader is seen in the design view of VS, so it is irrelevant. It should be working.

I tried with audi.ASE, and tried running things from Source, all was ok. But trying to run my own model, ends with failure.

Maybe its problem with the ase file I made. Was trying to compare ASE files (ones You gave and ones I made), can't catch the difference...

I would be gratefull if You could look at my project, and mybe find what is wrong...

http://dl.dropbox.com/u/27432050/BalderProg.zip

Thanks in advance.

Coordinator
May 22, 2011 at 10:21 PM

Running your project gives me a Balder specific exception saying that the textures need to be a power of 2 in size. This is a limitation in Balder, all textures must be having width and height the power of 2 (2, 4, 8, 16, 32, 64 etc..).

 

Hope that helps.