Help with textureing error?

Sep 21, 2010 at 11:23 AM
Hello group.
I am just getting started testing Balder out as a replacement for Kit3D in a project that has recently gone live on the web here:
The Silverlight content I created for the site is the "Design Your Own Shed" configurator which can found from the link on the page above, or here:
In the upper menu there is a flashing button for "3D Viewer" which shows the Kit3D version of what I'm trying to do.
Anyway.....  I'm just testing Balder to see if it works better, and have created a simple textured cube viewer UserControl. My current problem is the texture is showing up but looks very strange, sort of like a negative of the actual image. I've tried both png and jpg versions of the texture image.
Here is the relevant code:
<Execution:Game x:Name="Game" Width="610" Height="450" Margin="15" Background="#FFE5C764" MouseLeftButtonDown="Game_MouseLeftButtonDown" MouseLeftButtonUp="Game_MouseLeftButtonUp" MouseMove="Game_MouseMove" MouseLeave="Game_MouseLeave">


<View:Camera Position="0,0,-150" Target="0,0,0" />


<Geometries:Box x:Name="Box001" Dimension="30,30,30" ItemsSource="{Binding}">


<Materials:Material Ambient="White" Shade="Gouraud" DiffuseMap="/BalderViewer;component/TestPattern_1024x1024.JPG" />



<Lighting:OmniLight Position="30,30,-60" />


Any help figuring out what I've done wrong will be greatly appreciated.
Thank you 
Don Casteel 
Sep 21, 2010 at 6:13 PM
Hi, Glad you're looking at Balder, hope you won't get disappointed. Your Xaml looks right. Could you post an image of what you get as a result, and possibly attach the original texture as well. Are you using the latest binaries or the current source? A lot has happened since, so it might be worth looking at getting the latest source, if you haven't already.
Sep 22, 2010 at 12:08 PM


As for the version, I downloaded the binaries on September 13th,  Version
I have not yet downloaded the source code, but probably will soon so I can look stuff up.

For some reason posting from email isn't working, (I use Yahoo mail, if there's an known issue with Yahoo please let me know)

Using the forum online at codeplex doesn't seem to alllow attachments, and the live links buttons are grayed out, so I put everything in my project hosting site

Here's a url for the texture image:

Here's a url for the screenshot of the problem: you'll see a black cube with lighter lines that appear to be the large circles in the above image.

Here's a zipfile of the User Control which has all the Balder stuff in it

And here's the main Silverlight test project (very simple) where the above viewer is used All this does is place the control in a Silverlight page with methods to display/hide the viewer.

Thanks for all your help and support




Sep 27, 2010 at 5:09 PM

We solved this offline - so for anyone else reading here, the problem was that Expression didn't live up to its promise of outputting a 1024x1024 image, but outputted instead a 1016x1016 image.
Balder only supports power of 2 texture sizes.