Rotation Pivot point

Feb 26, 2010 at 11:41 PM

Is there a way to set a pivot point for rotation?

I notice that pivot point is actually Scene position (0,0,0)...

Thx

Feb 26, 2010 at 11:48 PM

Ok... i know im a pain in the ass :P

But is scene position (0,0,0) centered in game coords?

Like game.Width=1000 game.Height=1000 should position (0,0,0) render at the center of game?

Okay, chill out time...

Do u know what's the definition of women intuition?

Its the result of million of years without thinking...

 

P.S. Dont tell ur wifes...bad idea... already tried that :D

 

Feb 27, 2010 at 3:45 AM

ok... pratical example...

 

i have this meshs in game

<Geometries:Mesh x:Name="mshRing1" Rotation="0,0,0"    Material="{StaticResource ringMaterial}" AssetName="Portfolio;component//Assets/ring.ase" IsVisible="True"/>

<Geometries:Mesh x:Name="mshRing3" Rotation="0,45,0"   Material="{StaticResource ringMaterial}" AssetName="Portfolio;component/Assets/ring.ase" IsVisible="False"/>

same object in the diferent meshs...

This is what i get...

Photobucket

with these properties

Photobucket

There is a displacement here in X axis...both rings boundingsphere center should be (0,0,0)...

its not...Its...

        mshRing1.BoundingSphere .Center     {(0, 0, 5, 1)}    Balder.Core.Math.Vector
        mshRing3.BoundingSphere .Center    {(0, 0, 5, 1)}    Balder.Core.Math.Vector

 

So my guess is that something is wrong with the Rotation, that lead us again to the Pivot point...

 

Thx for ur time :D

 

 

Coordinator
Feb 27, 2010 at 7:47 AM

Hi,

Pivot point is supported - but there is a bug that causes the pivot not to be inherited from Mesh and down to the individual geometries within the Mesh.

I will look into it soon.

Coordinator
Feb 27, 2010 at 7:48 AM

Btw:

In the latest source code at GitHub, there is a ring primitive - and it should support Pivot point.

Feb 27, 2010 at 11:11 AM

Yeah i noticed the ring primitive, but when i use it it did not render...

Then i tried to set the Dimension Property but it didnt exist :(

So i saw the Ring.cs file and only an empty constructor was there...no PrepareRing() method available....

 

Coordinator
Mar 1, 2010 at 5:54 AM

Did you get the source from the Development branch ? 

 

Mar 3, 2010 at 5:11 PM

Yes...but the zip...

Im having problems sincronizing Git..

Coordinator
Mar 3, 2010 at 6:43 PM

I've been getting a few reports on people having trouble with Git, and to be honest, I've encountered a few myself.  I'm in the process of learning Mercurial and looking and the possibility to pull the source back to Codeplex - which would make a lot more sense. Better to have the source close to the actual home of the project. 

 

Mar 4, 2010 at 12:39 AM

Ok...i followed codeplex instrutions to Mercurial and Tortoise but i can see ur still in testing...

Ill be waiting...thx

Coordinator
Mar 15, 2010 at 11:06 AM

Just wanted to give you heads up. 

I've been working on pushing the code back to Codeplex - but I'm not able to, get some connection error while trying to push it. Codeplex is looking into what the issue is, as soon as they've figured it out, the code will be pushed to Codeplex and everything will be peachy. :)
You can follow the issue I've posted for Codeplex here

Coordinator
Mar 15, 2010 at 11:05 PM

Source has now been moved over to Codeplex again - and you can start using Mercurial to pull the source.

Mar 16, 2010 at 2:45 AM

Ok...thx for the update... :)

Mar 16, 2010 at 11:41 PM

Hi,

I've just cloned Balder in Codeplex without any problem...

As i understood from the issue link u send me, u still having problems in pushing source,

hope u get over that soon...

As for me...i'm going to explore the source code for a bit... :D

Coordinator
Mar 17, 2010 at 8:40 AM

It was only the initial push that was the problem. Everything is working as expected now, I'm pushing code again - and that makes me very happy.. :)

Coordinator
Mar 17, 2010 at 8:56 AM

BTW:

The original problem posted in this post (Pivot) should now be fixed.

Pivot is now part of the rendering world matrix for a Node graph and is inherited hierarchically through the rendering tree of a node.